Jump to content
smallbore

Server Time

Recommended Posts

probably got confuseled between GMT and BST ...

 

[robin@laptop robin]$ HEAD www.stirton.com

200 OK

Connection: close

Date: Wed, 16 Feb 2005 01:10:54 GMT

Server:

Content-Type: text/html

Client-Date: Wed, 16 Feb 2005 01:10:54 GMT

Client-Peer: 213.151.39.76:80

Client-Response-Num: 1

X-Powered-By: PHP/4.3.10

 

hmm ... it thinks its running in GMT, and its spot on to the second, so must be running some form of ntpd, so the server itself is spot on with its clock, its just the Powerboard BBS software thats got an hour offset in ... generally, the server will run on GMT all year ... its up to user programs to correct for timezone. Looks like Invision Powerboard isnt tracking the BST/GMT changes ...

Share this post


Link to post
Share on other sites

I thought this was down to you to put right in the "My Controls" section to suit where you are etc and there is a GMT/summer time adjustment available.

Share this post


Link to post
Share on other sites

I suspect people have simply got used to their system automatically setting their local clock to BST/GMT as it changes, you don't normally need to go through the various applications you use and set them by hand ...

 

What it seems to be is a design-oddity in Powerboard ... messages arriving at the server are stored according to a timestamp generated by the servers clock, GMT. As each page is generated for the user, the time is "adjusted" so if you happen to be a user in Australia and its midnight UK time, Mid-day australia time, someone posts a message at ten-to-midnight UK time, it will appear as "posted 11:50am" to the australian user and "posted 11:50pm" the UK user ... the displayed time is created from the posted time to be relevant to what the user has set intheir timezone settings in thier PowerboardBBS settings.

 

The oddity is, that instead of picking the time zone you are in out of the request sent from your browser like most other systems do, powerboard requires you to make a manual change to your settings, which is a bit odd, I can see why it confuses people, as its not intuitive that you should have to even tell the the BBS software such a thing.

 

On the plus side, it only affects the users local display of the postings, the actual posting timestamps are always recorded in the database as GMT.

Share this post


Link to post
Share on other sites

Remember folks, you may not have set the "automatic" timezone setting ticked.

 

At the top right of the screen, you will see your name and a drop-down arrow.

Click on the arrow and then "My Settings"

 

Under General Settings, you should see a Timezone section and an option for "DST correction" ... tick this and save the settings.

 

Hopefully, now you are posting with the 'correct time' :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×